2950是只支持二层的交换机
支持VLAN
第1步:单击“开始”按钮,在“程序”菜单的“附件”选项中单击“超级终端”
第2步:在“名称”文本框中键入“Cisco”
第3步:在“连接时使用”下拉列表框中选择与交换机相连的计算机的串口。台式机为“com 1”,笔记本为“com 3或者com 5”。
第4步:在“波特率”下拉列表框中选择“9600”-确定.
如果通信正常的话就会出现类似于如下所示的主配置界面,并会在这个窗口中就会显示交换机的初始配置情况。
enter
enter
enter
no!
1)配置交换机姓名
switch>ena
switch#configure
enter
switch#configure terminal (进入配置状态)
Switch(config)#hostname 配置的交换机姓名 如:30FLoor-2960-1
30FLoor-2960-1(config)#end
30FLoor-2960-1#
2)配置交换机的ip
30FLoor-2960-1#configure terminal (进入配置状态)
30FLoor-2960-1(config)#interface vlan 1
30FLoor-2960-1(config)#ip address ip地址 子网掩码
例如:30FLoor-2960-1(config)#ip address 10.11.90.10 255.255.255.0
30FLoor-2960-1(config)#no shutdown
30FLoor-2960-1(config)#end
30FLoor-2960-1#
30FLoor-2960-1#
3)配置交换机的 默认网关
30FLoor-2960-1(config)#ip default-gateway 网关ip
例如:30FLoor-2960-1(config)#ip default-gateway 10.11.90.254
4)设置路由
30FLoor-2960-1(config)#ip route 0.0.0.0 X.X.X.X
5)设置console口密码
30FLoor-2960-1(config)#line console 0
30FLoor-2960-1(config-line)#password 输入密码
30FLoor-2960-1(config-line)#login
30FLoor-2960-1(config-line)#end
6)设置telnet的密码
30FLoor-2960-1(config)#line vty 0 10
30FLoor-2960-1(config-line)#password 输入密码(yuxuan)
30FLoor-2960-1(config-line)#login
30FLoor-2960-1(config-line)#end
7)设置交换机的enable密码
30FLoor-2960-1(config)#enable password 输入密码(xuan)
30FLoor-2960-1(config)#enable secret 输入密码(yuxuan)
30FLoor-2960-1(config)#end
8)将当前配置信息保存到闪存中
30FLoor-2960-1(config)#write
9)查看交换机信息
30FLoor-2960-1#
show version 查看交换机版本信息
show ip interfaces 查看交换机的ip地址
show interface vlan 1 验证管理ip地址已经配置并开启
show ip redirect 查看交换机的网关
show running-configure 查看交换机当前的配置信息
show configure 查看交换机保存的配置信息
switch#write ; 保存配置信息
switch#show vtp ; 查看vtp配置信息
switch#show run ; 查看当前配置信息
switch#show vlan ; 查看vlan配置信息
switch#show interface ; 查看端口信息
switch#show int f0/0 ; 查看指定端口信息
10)交换机基本配置步骤
1.登陆到交换机
2.进入特权模式
命令:enable
3.进入全局配置模式
命令:configure terminal
4.进入相应的配置子模式
如:接口子模式
命令:interface vlan 1
交换机基本状态:
switch: ;ROM状态, 路由器是rommon>
hostname> ;用户模式
hostname# ;特权模式
hostname(config)# ;全局配置模式
hostname(config-if)# ;接口状态
交换机口令设置:
switch>enable ;进入特权模式
switch#config terminal ;进入全局配置模式
switch(config)#hostname ;设置交换机的主机名
switch(config)#enable secret xxx ;设置特权加密口令
switch(config)#enable password xxa ;设置特权非密口令
switch(config)#line console 0 ;进入控制台口
switch(config-line)#line vty 0 4 ;进入虚拟终端
switch(config-line)#login ;允许登录
switch(config-line)#password xx ;设置登录口令xx
switch#exit ;返回命令
交换机VLAN设置:
switch#vlan database ;进入VLAN设置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;删vlan 2
switch(config)#int f0/1 ;进入端口1
switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2
switch(config-if)#switchport mode trunk ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan
switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
switch(config)#vtp domain ;设置发vtp域名
switch(config)#vtp password ;设置发vtp密码
switch(config)#vtp mode server ;设置发vtp模式
switch(config)#vtp mode client ;设置发vtp模式
交换机设置IP地址:
switch(config)#interface vlan 1 ;进入vlan 1
switch(config-if)#ip address ;设置IP地址
switch(config)#ip default-gateway ;设置默认网关
switch#dir flash: ;查看闪存
交换机显示命令:
switch#write ;保存配置信息
switch#show vtp ;查看vtp配置信息
switch#show run ;查看当前配置信息
switch#show vlan ;查看vlan配置信息
switch#show interface ;查看端口信息
switch#show int f0/0 ;查看指定端口信息
思科2950交换机VLAN划分
cisco
首先配置一下交换机
SC-2950>
SC-2950>en
SC-2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SC-2950(config)#config-register 0x2102
SC-2950(config)#end
添加三个VLAN
SC-2950#vlan data
SC-2950(vlan)#vlan 10 name v1
VLAN 10 added:
Name: v1
SC-2950(vlan)#vlan 20 name v2
VLAN 20 added:
Name: v2
SC-2950(vlan)#vlan 30 name v3
VLAN 30 added:
Name: v3
SC-2950(vlan)#exit
APPLY completed.
SC-2950#
划分接口到各个VLAN
SC-2950#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SC-2950(config)#int fa0/1 //留给管理员
SC-2950(config-if)#switchport mode access
SC-2950(config-if)#sw acc vlan 10
SC-2950(config-if)#no shutdown
交换机 路由器SC-2950(config-if)#exit
SC-2950(config)#int range f0/2 - 15
SC-2950(config-if-range)#sw mode acc
SC-2950(config-if-range)#sw acc vlan 20
发布评论